Security Notice

Effective December 11, 2017, CharterNet Online Banking will require TLS 1.2 or higher to align with industry best practices for security and data integrity.  To avoid any disruption to your Online Banking access you may need to upgrade your web browser or operating system to support TLS 1.2.


TLS stands for “Transport Layer Security.” It is a protocol that provides privacy and data integrity between two communicating applications. It’s the most widely deployed security protocol used today, and is used for web browsers and other applications that require data to be securely exchanged over a network. TLS ensures that a connection to a remote endpoint is the intended endpoint through encryption and endpoint identity verification. The versions of TLS, to date, are TLS 1.0, 1.1 and 1.2.

Operating System and Browser Information and Testing
You can go here: http://www.whatsmybrowser.org/.  This will tell you the version of your browser and operating system.
You can go here: https://www.howsmyssl.com/.  It will evaluate your TLS and tell you what version you are using, and if its “Good” or “Bad”.  


Operating Systems


Windows:
  Minimum of Windows 7.  Windows XP or Windows Vista operating systems can only upgrade to Internet Explorer 8, which is not compatible with TLS 1.2 or higher.  Alternatively use Google Chrome or Mozilla Firefox web browsers OR upgrade to a newer operating system.

Apple:  In Apple operating systems versions of 10.8 or less the Safari browser is not compatible with TLS 1.2.  Upgrade the Apple Operating System (10.8 or higher) to get a newer version of Safari or use Google Chrome or Mozilla Firefox.  Mobile iOS 4 and below is not compatible.

Android:  Jelly Bean 4.3 and below will not be compatible.


Browsers


Microsoft Internet Explorer

  • Internet Explorer 11 (Desktop & Mobile): Compatible by default (though may need to be configured to explicitly disable TLS 1.0)
  • Internet Explorer 10, 9, and 8 (Desktop): Compatible on Windows 7 or newer if configured properly. Not compatible on Windows Vista, Windows XP, or older.
  • Internet Explorer 7 & Older (Desktop): Not compatible
  • Internet Explorer 10 & Older (Mobile): Not compatible

Configuration:

  1. Open Internet Explorer
  2. Click Alt T and select “Internet Options”.
  3. Select the “Advanced” tab.
  4. Scroll down to the “Security” section.
  5. Locate and check “Use TLS 1.2”.
  6. Uncheck “Use TLS 1.0” and “Use TLS 1.1” if checked.
  7. Then, press the “OK” button.

Microsoft Edge

Edge: Compatible by default

Google Chrome

  • Chrome 38 & Newer: Compatible by default
  • Chrome 22-37: Compatible on certain operating system versions by default
  • Chrome 21 & Older: Not compatible

Configuration:

  1. Open Google Chrome
  2. Click Alt F and select “Settings”.
  3. Scroll down to the bottom of page and select “Show advanced settings…”
  4. Scroll down to the Network section and click on “Change proxy settings…”
  5. Select the “Advanced” tab.
  6. Scroll down to the “Security” section.
  7. Locate and check “Use TLS 1.2”.
  8. Then, press the “OK” button.

Mozilla Firefox

  • Firefox 27 & Newer: Compatible by default
  • Firefox 23-26: Compatible if configured properly
  • Firefox 22 & Older: Not compatible

Configuration:

  1. Open FireFox
  2. Type in “about:config” in the URL bar and press Enter
  3. Scroll down to “security.tls.version.max” and press enter
  4. Set the value to 3
  5. Then, press the “OK” button.

Apple Safari

  • Safari 7 & Newer (Desktop): Compatible by default
  • Safari 7 & Older (Desktop): Not compatible
  • Safari 5 & Newer (Mobile): Compatible by default
  • Safari 4 & Older (Mobile): Not compatible

Configuration:

  1. There are no options for enabling SSL protocols. If you are using Safari version 7 or greater, TLS 1.2 is automatically enabled.
  2. As noted previously, if you are on a Mac Operating system of 10.8 or less, TLS 1.2 will not be available. On Mobile, if user has iOS 4 and below TLS 1.2 is not supported.

Google Android Browser

Android 5.0 (“Lollipop”) & Newer: Compatible by default
Android 4.4 (“KitKat”): Compatible on certain devices by default
Android 4.3 (“Jelly Bean”) & Older: Not compatible